Xyphien Forums

Hello Guest!. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, sell your games, upload content, as well as connect with other members through your own private inbox!

Weird Plugin Command error?

jaye

Villager
Xy$
0.00
debug.png Every time I use a plugin command, I get this message ' Cannot read property '1' of undefined'. It doesn't matter what plugin I do it in or which command I use, I keep getting the same error message. Does anyone know what this is or how to fix it?
 
Last edited:

LTN Games

Master Mind
Resource Team
Xy$
0.00
When you get the error open your console by pressing F8. Once done, upload it here and it should help us further determine the problem. It's most likely one plugin conflicting with another and causing all of them to crash the game.
 

jaye

Villager
Xy$
0.00
When you get the error open your console by pressing F8. Once done, upload it here and it should help us further determine the problem. It's most likely one plugin conflicting with another and causing all of them to crash the game.
added screenshot to post
 

LTN Games

Master Mind
Resource Team
Xy$
0.00
It seems Galv's Quest Log is throwing an error which could cause issues. Aside from that apparently one of the plugin commands is trying to find property 1 of an undefined variable. Maybe one of the plugin commands you're using is setup wrong ? Specifically MOG Picture Effects
 

jaye

Villager
Xy$
0.00
It seems Galv's Quest Log is throwing an error which could cause issues. Aside from that apparently one of the plugin commands is trying to find property 1 of an undefined variable. Maybe one of the plugin commands you're using is setup wrong ? Specifically MOG Picture Effects
Oh ok. I'm going to go through everything and maybe I can figure it out.
 

CT_Bolt

Global Moderator
Staff member
Resource Team
Xy$
0.00
Every time I use a plugin command, I get this message ' Cannot read property '1' of undefined'. It doesn't matter what plugin I do it in or which command I use, I keep getting the same error message. Does anyone know what this is or how to fix it?
Line 99:30: if ($gameScreen.picture(args[1])) {this.setPictureEffects(command, args)};

Which might mean\ that you haven't specified a argument for the command.
(be sure to use the spaces as they are actually separators used by the game interpreter in the plugin command)

May I see how you use your plugin command?
 
Last edited:

jaye

Villager
Xy$
0.00
Glad to hear it. (cool)(thumbsup) Mind sharing the solution? (icecream)
Well, it kinda sucks, but now I m getting a different error. It says 'toLowercase'. I checked the log and it said that it couldn't the font file, that is clearly in the fonts folder. (For the other thing, I removed Moghunter's maps from the project for now.)
 

Boy Who Codes

Praised Adventurer
Xy$
0.00
toLowerCase happens usually when dealing with the actual pluginCommand function. In what part does the toLowerCase error happen?
 

jaye

Villager
Xy$
0.00
toLowerCase happens usually when dealing with the actual pluginCommand function. In what part does the toLowerCase error happen?
I was doing the gab window.
GabText
ShowGab
 
Top